Tapestry 5.3.6 not recognising named queries

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Tapestry 5.3.6 not recognising named queries

Qbyte Consulting
Hi,

I have a Maven dependency tree like this:
Entity Classes
DAO Layer
DAO Consumer (Tynamo resteasy layer)

java.lang.IllegalArgumentException: NamedQuery of name:
EUser.findByUsername not found.

In my consumer project everything runs, I can see the entity classes
registering in JPA and my DAO is wired up, but somehow the named queries
aren't available. Any ideas why?

I thought if I referenced the Entity Classes dependency directly in my
consumer layer that it may help because if I access the Entity Classes as a
direct dependency they work.

John

[EL Config]: metadata: 2016-08-01
14:51:09.96--ServerSession(27246127)--Thread(Thread[main,5,main])--The
alias name for the entity class [class EUser] is being defaulted to: EUser.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tapestry 5.3.6 not recognising named queries

Jay Ginete
Assuming your using JPA, is the Entity class explicitly mapped in the
persistence.xml? I've had a problem similar to this is if just do a package
mapping instead of explicitly mapping each class.

On Mon, Aug 1, 2016 at 10:01 PM, Qbyte Consulting <[hidden email]
> wrote:

> Hi,
>
> I have a Maven dependency tree like this:
> Entity Classes
> DAO Layer
> DAO Consumer (Tynamo resteasy layer)
>
> java.lang.IllegalArgumentException: NamedQuery of name:
> EUser.findByUsername not found.
>
> In my consumer project everything runs, I can see the entity classes
> registering in JPA and my DAO is wired up, but somehow the named queries
> aren't available. Any ideas why?
>
> I thought if I referenced the Entity Classes dependency directly in my
> consumer layer that it may help because if I access the Entity Classes as a
> direct dependency they work.
>
> John
>
> [EL Config]: metadata: 2016-08-01
> 14:51:09.96--ServerSession(27246127)--Thread(Thread[main,5,main])--The
> alias name for the entity class [class EUser] is being defaulted to: EUser.
>



--


[image: Jay Ginete on about.me]

Jay Ginete
about.me/jay.ginete
  <http://about.me/jay.ginete>
Loading...