Re: [T4.1.5] RadioGroup EventListener doesn't work

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [T4.1.5] RadioGroup EventListener doesn't work

Marcus Schulte
Sorry guys,

I've forgotten the version-hint in the docs.  The feature was committed to
trunk end of march. Currently, it's only available in version
4.1.6-SNAPSHOT. I meant to push a release, but then, I never got around.

Marcus

2008/7/4 Christophe Mesplede <[hidden email]>:

> Hi.
>
> I experienced the exact same problem trying to use the RadioGroup Ajax
> behaviour.
> As you did, I also tried the sample code from the documentation, it did not
> work.
> Finally, I gave up the Ajax way, and added a looot of stuff in javascript
> to
> make
> some kind of workaround, but with no server interaction :(
>
> Anyway it's sad neither of us managed to make this work. I wonder if
> someone
> on
> the mailing list ever used this ability of the RadioGroup...
>
> Regards,
> Chris
>
>
> > Hi,
> > When trying to you the onChange method on a RadioGroup component, we
> > encountered the following error client side :
> >
> > [Exception... "'Error: bad srcObj for srcFunc: onChange' when calling
> > method: [nsIDOMEventListener::handleEv> ent]"  nsresult: "0x8057001c
> > (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "<unknown>"  data: no]
> >
> > We thought we did something wrong so we started back from the Ajax
> > example on the tapestry website
> > (http://tapestry.apache.org/tapestry4.1/components/form/radiogroup.html
> ).
> > Still doesn't work.
> >
> > Do you have an idea ?
> > How to made the example work, is there something missing ?
> >
> > Best regards,
> > Jérome.
>



--
Marcus Schulte
http://marcus-schulte.blogspot.com
Loading...